The Minecraft Overviewer

a high-resolution Minecraft world renderer with a Google Maps interface


Overviewer.org APT Repository

This is the Overviewer.org APT Repository, which hosts frequent builds of Minecraft Overviewer for use on Debian-based systems, such as Ubuntu or Debian itself. In order to use this repository, add the following line to your /etc/apt/sources.list:

deb http://overviewer.org/debian ./

To install the GPG key used to sign this repo, run this:

wget -O - http://overviewer.org/debian/overviewer.gpg.asc | sudo apt-key add -

Then, run apt-get update as root to update your repository information.

Installing Overviewer is as simple as running apt-get install minecraft-overviewer. Since this repository is updated whenever the code changes, you can also upgrade through APT. To upgrade, run apt-get update, then apt-get install minecraft-overviewer again.

This package will work on any Debian-based system that supports Python 2.6 or Python 2.7, which is just about everything. Still, if you have any issues with these packages, please let us know in IRC or email the maintainer at agrif@overviewer.org.

Also note that these packages only work on x86 and x86_64. This means that these binary packages will not work on your Raspberry PI (which is ARM). Of course, you can still build Overviewer from source.

Notes for Ubuntu 10.04 (Lucid Lynx) and Earlier

These versions of Ubuntu have a bug that causes an error message when installing Overviewer. Note that Overviewer will still work, even with this error message, so please ignore it. If you want, you can bug the Ubuntu devs about it here.